Delay in Communications and Calendar Sync
Resolved
The issue has been resolved.
Posted Jun 16, 2023 - 18:50 BST
Investigating
We are currently experiencing delays in our calendar sync and messaging!
Posted Jun 16, 2023 - 18:12 BST
This incident affected: Communications and Calendar Sync.