System Issue
Resolved
The issue is resolved, and the system should be working as expected.
Posted Apr 05, 2023 - 11:28 BST
Investigating
We see reports of error messages on 10to8. Users currently see a "We're sorry" message when accessing the system. We are working on a fix for this.

Our team is investigating, and we will update you as soon as we have any further news.
Posted Apr 05, 2023 - 11:15 BST
This incident affected: SISc Web-Application, Communications, and Calendar Sync.