Performance Issue on US Server
Resolved
Our engineers have released updates to the system, which fixes the issues experienced!
Posted Jan 26, 2023 - 17:20 GMT
Investigating
We have received reports of performance issues on our US Server that our engineering team is currently investigating.
Posted Jan 26, 2023 - 15:13 GMT
This incident affected: SISc Web-Application.