Delays in Notifications and Calendar Sync
Resolved
This incident has been resolved.
Posted May 13, 2021 - 16:00 BST
Investigating
We are investigating issues that are causing some delays with our Notifications (EMails & SMS) as well as with our Calendar Sync.
Posted May 13, 2021 - 15:41 BST
This incident affected: Communications and Calendar Sync.