Delay with notifications and calendar sync
Resolved
This incident has been resolved.
Posted May 05, 2021 - 17:50 BST
Identified
We are experiencing a 10 - 15 minute delay with our Email/SMS notification and our calendar sync. Our engineers are working on the issue!
Posted May 05, 2021 - 17:27 BST
This incident affected: Communications and Calendar Sync.