Delays in communications
Resolved
This incident has been resolved and all messages should be sent out.
Posted Aug 16, 2018 - 20:41 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 16, 2018 - 19:56 BST
Investigating
We are currently investigating delays in messages being send out.
Posted Aug 16, 2018 - 19:52 BST
This incident affected: Communications.