Google Calendar Changes
Resolved
This incident has been resolved.
Posted Jun 21, 2018 - 08:56 BST
Monitoring
A fix is being released by Google.

You can follow the issue in more details on Cronofy's status page (https://status.cronofy.com/) and on Google's issue tracker (https://issuetracker.google.com/issues/110373170).
Posted Jun 20, 2018 - 16:23 BST
Investigating
Due to some errors in the subscription to changes from a Google Calendar some appointment changes might not be reflected on 10to8.

You can follow the issue in more details on Cronofy's status page (https://status.cronofy.com/) and on Google's issue tracker (https://issuetracker.google.com/issues/110373170).
Posted Jun 20, 2018 - 09:46 BST
This incident affected: Calendar Sync.