Performance Issues
Resolved
The issue has been resolved and all emails and SMS messages are now catching up.
Posted Jun 21, 2018 - 17:24 BST
Monitoring
A fix has been implemented and we are monitoring the result.

There might be delays in messages being sent out as a result of this. Nevertheless, rest assured, we will send out all communications.
Posted Jun 21, 2018 - 17:12 BST
Investigating
We are currently investigating performance issues in our web app.

This issue is causing the product to run slow and an unuaually high number of error messages to appear.
Posted Jun 21, 2018 - 17:07 BST
This incident affected: SISc Web-Application.