Delay in Communications
Resolved
We have resolved the issue and caught up with all communications. If you still experiencing issues with our communications please do let us know under support@10to8.com.
Posted Mar 24, 2017 - 13:25 GMT
Identified
We have identified delays with all messages send via 10to8 and are currently working on resolving those.
Posted Mar 24, 2017 - 13:11 GMT