Speed Issues
Resolved
This incident has been resolved.
Posted Oct 09, 2018 - 19:29 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 09, 2018 - 19:12 BST
Investigating
We are currently investigating this issue.
Posted Oct 09, 2018 - 18:35 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 09, 2018 - 17:53 BST
Investigating
We are currently investigating some speed issues that might prevent you from loading 10to8.
Posted Oct 09, 2018 - 16:57 BST
This incident affected: SISc Web-Application.